
TRAINING PROGRAMME ON UTILISATION OF SPSS 
SOFTWARE PACKAGE FOR QUANTATTVE EDUCATIONAL 
DATA FOR THE FACULTY OF REGIONAL INSTITUTE OF

EDUCATION (NCERT), MYSORE

Report

Dates:
30th November to 4th December 2004

Team:
Dr. G. Viswanathappa Coordinator 
Dr. D. Basavayya, Co-coordinator

Regional Institute of Education (NCERT) 
MYSORE - 570 006



SPSS PC Tour contents
SPSS PC TOUR CONTENTS 2

STARTING OFF 3

V STARTING UP SPSS 4

© SPSS FOR WINDOWS DIALOG 5

» DATA IN THE SPSS DATA EDITOR 7

SPSS phrase book 9

© RUNNING AN ANALYSIS 11

© FREQUENCIES 12
More information on procedures 14

Frequencies: Charts, Specifying a bar chart 17

Frequencies Format 18

© THE OUTPUT VIEWER 19
Hiding the outline 20

Using the outline 22

About the Frequencies output 23

© CROSSTABS 25

© LEAVING SPSS 27

CD INFORMATION 29

» Tilings to do... 29

Go on Computing Services courses 29

Go on courses in your department 29

Look at SPSS notes on-line 29

Go on another tour 29

» Places to visit... 30

The Labs 30

The web pages 30

0 People to see... 30

Lab Supervisors 30

Help Desks 30

SPSS IO-1 l.5 SPSS PC TOUR - 2



SPSS 11.5 for Windows Installation

SPSS 11.5 for Windows 98/ME/XP/2000/NT
Installation instructions

1. Make sure there is 84 megabytes of available space on the hard drive before installation of
this program.

2. Make sure you have the “serial number” and “license code” for SPSS. This information
would have been emailed to you. Keep a printout of this email handy so you can type in 
the “serial number” and “license code” when prompted during the installation.

3. Insert the “SPSS 11.5 for Windows” CD into the disk drive. After several seconds the
install splash screen will appear. If the install wizard fails to activate then press “Start | 
Run“ menu items. Navigate the Run dialog box to the CD-ROM containing the software 
and select the “setup.exe” executable file. Press the “Open” button to select the program 
and return to the run dialogue box then press the “Ok” button to activate the setup 
program.

wlw ■ law
Install SPSS
Install SmartViewer
Installation Instructions
Install Internet Explorer 6.0
Install Acrobat Reader 5.0
Install SPSS Data Access Pack
Browse the CD-ROM
Exit

www.spss.com
>6 ZOOJ SPSSlac. AM iis)lsits (eatveil.

Click on ‘Install SPSS’.
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x|Welcome

Welcome to the SPSS for Windows Setup program. This 
program will install SPSS for Windows on your computer.

It i? strongly recommended that you exit all Windows programs 
before running this Setup program.

Click Cancel to quit Setup and then close any programs you have 
running Click Next to continue with the Setup program

WARNING This program is protected by copyright law and 
international treaties.

Unauthorised reproduction or distribution of this program, or any 
portion of it, may result in severe civil and criminal penalties, and 
will be prosecuted to the maximum extent possible under law.

f" Next > Cancel

Click on ‘Next’.

Software Lice

/V Please read the following software license agreement. You will 
need to use the jcroll bars to read the complete text.

(THIS LICENSE AGREEMENT IS YOUR PROOF OF LICENSE.

i THIS IS A LEGAL AGREEMENI FOR A SINGLE-USER LICENSE OF 

THE SOFTWARE BETWEEN YOU (EITHER AN INDIVIDUAL OR ENTITY1 
■AND SPSS INC If you do not agree to the terms of this
Lie en.e Agreement, immediately return the package. This
Lie en.’.e Agreement shall apply only if you have not signed
another SPSS License Agreement for this software

This software is protected by both United States copyright
llaw and international copyright treaty provisions

Do you accept the terms a? ?et forth above?

Back 1 | Yes No

2£J

1

d

6. Click on ‘Yes’.
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Setup will install SPSS for Windows in the following directory. 

To install to thio directory click Next

To install to a different directory, click Browse and select another

You can choose not to install SPSS for Windows by clicking 
Cancel to exit Setup.

Destination Directory 

C:\Program Files\SPSS Browse.

■, Back Cancel

7. Click on ‘Next’.

User Information ....................... BIlMllltB
Enter your name, organisation, and the serial number that is 
printed on the CD-ROM case

2d

Name- j

Organisation |

Serial number

< Back. Next, Cancel

Under ‘Name’, enter your name, under ‘Organization’, enter ‘University of Cincinnati’, 
and under ‘Serial number’, enter the serial number supplied to you in the e-mail. Once 
this is done, click ‘Next’.
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Setup Type Xj

,S Select the type ot installation you prefer.

; ( ‘ Typical Program will be installed with the most common 
options. Recommended for most users

—8

( Compact Program will be installed with minimum required

(* Cy; torn You rnay choose the options you want to install. 

Recommended tor advanced users

Back Next > Cancel

Choose ‘Custom’ and click on ‘Next’.

Select the component; you wish to install.

P :Sample Data [1 MB}

P BASIC Scripting [2 MB]

P Production mode facility [1 MB]

P S tahstic: Coach (requires IE 4.0 or higher I [2 M B ] 

P Syntax Guide [IS MB]

xj

: Back Next > Cancel

Check the ‘Syntax Guide (16 MB)’ check box and click on ‘Next’.
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Personal or Shari

■, Back I Next > Cancel

Click on ‘Next’.

2<J

SPSS ships with one or more license codes that govern the 
product? von may install Please enter the license codes one at a 
time, then pre?s Update to update the license status

1 License status.

SPSS tor Windows Base - unlicensed
SPSS Regression Models - unlicensed
SPSS Advanced Model; ■ unlicensed
SPSS Tables - unlicensed
SPSS Trends - unlicensed
SPSS Categories - unlicensed
SPSS Conioint • unlicensed
SPSS Exact Tests - unlicensed
SPSS Missing Value Analysis - unlicensed
SPSS Map ■ unlicensed
SPSS Tables Original - unlicensed

□

J
< Back Next > Cancel

Enter the license number which has been e-mailed to you in the box above. Be sure to enter 
the license number without any dashes. Then click ‘Next’.
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Select Options 2d

Select the SPSS options you have licensed and wish to install.

P SPSS Regression Models [1 0 MB]

I? SPSS Advanced Models [2 5 MB]

P SFSS Tables [3 0 MB]

P SPSS Trends [1.0 MB]

17 SPSS Categories [i 0 MB]

P S PS S T ables Original [0.7 M B ]

< Back | Next > j Cancel

Click ‘Next’.

At this point the installation begins and you will see a screen like the screen above. Wait till 
the screen changes to the one shown below.
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[Ready To Install F

Setup is ready to begin the file transfer operation. Please 
review the information below. If you need to make changes, 
please backup and make correction; before continuing.

Current Setting;

Target Directory 
C ^.Program Files\SPSS

Components:
Sample Data —
BASIC Scripting
Production mode facility
Statistics Coach (require; IE4.0 or higher)
Syntax Guide

SPSS Options.
SPSS Regre;;ion Models T i

< Back t Cancel [

Click ‘Next’.
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You will see an install screen like the one shown above. Once the installation is complete, 
you get a screen like the screen below.

2<J

Registered users receive regular information on products and 
product updates You have not yet registered this product 
Select the ODtion vou orefer.

Register now 

Register later

Cancel

Select the option ‘Register later’ in the screen above and click ‘Next’.

Setup Complete

17 launch tutorial now?

Display the ReadMe file now?

SPSS for Windows Setup is now complete.

You may run SPSS for Windows by selecting the application 
icon in the program group

| Finish |
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Uncheck the ‘Launch tutorial now?’ and the ‘Display the ReadMe file now” checkboxes 
and click on ‘Finish’.

SPSS 11.5 for Windows
Uninstall instructions:

1. Select the following menu items to arrive at the dialogue box where you can 
uninstall the software package “Start | Settings | Control Panel | Add/Remove 
Programs”.

2. Scroll down the listing and select the entry for “SPSS 11.5 for Windows”
a. Click the Change/Remove button to active the “Remove programs from 

your Computer” wizard. The following components will be removed ...
i. Shared program files
ii. Standard program file
iii. Folder items
iv. Program folders
v. Program directories
vi. Program registry entries

3. A progress bar indicates the progression of the removal task.
4. You will receive uninstall completed message. Some elements could not be 

removed. You should remove items related to the application.
5. Click on the “Ok” button. The entry in the “Add/Remove Programs” listing will

disappear and disk space on the hard drive should increase by 82 megabytes.
6. Restart the computer.

.9.



Your very own Support team 30

Starting off
This is brief tour to whisk you round the main features of SPSS 10 to 11.5. Like any tour nothing is 
covered in great detail, the aim is to let you see how SPSS works.

The information symbol will be used to flag interesting areas and where to find out 
more. Go tothe information section at the end of the tour to find out about:-

(D Things to do... including SPSS courses.

(D Places to visit... such as useful web sites and where to find SPSS.

(D People to see... about getting help with SPSS and computers.
All you will need to follow this tour is a computer with SPSSfor Windows installed, any version 
from 10 to 11.5. If you have an Apple computer with SPSS 10 for Macintosh installed, there is 
separate tour for that.
So grab your hat and a computer and let’s visit the wonderful world of SPSS!

The mouse symbol will be used when you have to do something on the computer to 
follow the tour. In this case, switch on/log into the computer you are going to use.

SPSS 10-11.5 SPSS PC TOUR-3



Starting up SPSS
SPSS can be opened from Start menu. The button for the Start menu is usually at the bottom left 
hand corner of the desktop. Pic 1 is a picture of a PC desktop running Windows XP in the public 
labs. You can see from the Start menu, All Programs has been selected, from there Statistics has 
been chosen, and then from Statistics, SPSS 11.5 has been chosen and then SPSS 11.5 has been 
chosen from its menu.

Pic 1: Choosing SPSS from the SPSS directory
El

ytj j Search J i Favorites

:iS£| httpi/faww.ucs.ed.ac.uk/labs/

home { contact I help I search

Computing Services

■■■■I

I School Applications

If .) New Office Document 

I Open Office Document

■fTj Accessibility 

S.) Accessories 

Admin Toots 

Communications 

Database

igf[ Email & Newsreaders 

Graphics 

Mathematics 

Spreadsheets 

Startup

:r.) Streaming Media 

Utilities

Viewers

Word Processing

i Wj WWW

to the Open Access Computing Labs

TION FOR ALL STUDENTS USING THE
CESS COMPUTING LABS
vai e changes in the Open Access Computing Labs

diversity's Open Access Computing Labs as a consequence of our switching them from Windows 
;e University this Summer, these changes will affect you, so please read all of this message.

Minitabvl3 M

S-PLU5 6.0 Professional >1

;; :r storage device^^^^^^ 

i om the beginning of September.

" [My Documents to be stored for each student. This 
5PS5 Pro uction Facility hrindowg NT Desktop will be irretrievably lost You 

(the MA drive), or a floppy disk, or a CD/RW,

u In Public labs, click the Start button and choose All Programs, from there 
choose Statistics, then choose SPSS 11.5 and SPSS 11.5 again to open SPSS.

i) The exact sequence might vary depending on how the computer has been setup but 
SPSS should be available through the All Programs or Programs menu if it is there.
If you can't find it, search for the SPSS directory using the Start menu choose 
Search or Find, then select All files or folders or Files or Folders and search the 
computer for the word "spss".

SPSS lO-l 1.5 SPSS PC t o u r -4



® SPSS for Windows dialog
Starting up SPSS will open the SPSS for Windows dialog box shown in Pic 2.

Pic 2: First view of SPSS

SPSS should look like this in the Public labs and Computing Services training suite and when it is 
first installed (unless SPSS has been customised on the computer you are using). There are several 
choices of what to do next: -

Run the Tutorial runs a slide show tutorial to show SPSS’s main features.
Type in data presents an empty untitled data window SPSS Data Editor.
Run an existing query will run a query to bring data in from a database.
Create new guery using Database Capture Wizard takes you through creating your 
own query to extract data from a database or Excel.
Open an existing data source to select an SPSS or other type of data file to analyse. 
Open another type of fde to open any other sort of file.
Don’t show this dialog box in the future will stop the dialog box appearing in the 
future.

Click OK to choose Open an existing data source.
If you don’t see the dialog box shown in Pic 2 then use the Open File button (first left on the tool 
bar, see Pic 9) or choose File/Open/Data from the menus to activate the Open File dialog box. 
Starting up SPSS without the dialog box should open the SPSS Data Editor window, as in Pic 4 but 
without any data in it.

SPSS 10-11.5 SPSS PC t o u r  - 5



We will use a data set called 1991 U.S. General Social Survey.sav that comes with SPSS and in 
general there should be a copy of it in the folder where SPSS is installed. In the labs it is drive T, in 
the Skills centre there is a copy in the spsswork directory as well. On your own computer it is likely 
to be on the C or D drive in the Program Files or Programs folder. You might have to scroll to the 
right past lots of folders before you get to the data files.

Pic 3: Open File dialog box showing data (.sav) files in the Spssll folder

h pel 
.11 Open I ilc

Look in i' 1 SPSS

' 'ide

i sen 
( es
i

, to Help
i nti

ip?I. I dd
0®

. Type: SPSS Data Document 
Date Modified: 29/08/2002 20:33 
Size: 100 KB

OpenFilename: |l991 U.S, General Social Survey

Files of type: [SPSS fsavj ' Paste

: Cancel

jhwg ther 

lofthi

yj < 1 * |\D<itfi View /(VariableView /
SPSS Processor is ready

iT :d for ea 

be irretr 

w rltcjLr .

Select the file 1991 U.S. General Social Survey.sav and click Open to read 
the data file into the DataEditor window.
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Data in the SPSS Data Editor
Pic 4: Survey data without value labels

Now you should be able to see the Data Editor window dominated by the grid used to display and 
change existing data or enter new data. Use the vertical and horizontal scroll bars to see more of the 
data, there are over 1500 rows representing the opinions of people from all over the states. Above 
the grid and below the title bar are the menu headings as seen in Pic 5.

Pic 5: SPSS Data Editor detail, Menu Headings
File Edit View Date Trariiform Analyze Graph? Utilities Window Help

Click each heading to look at the sort of items on each menu.
Most menu items are greyed at and cannot be selected until there is some data in the Data Editor. 
The Help menu contains lots of useful information about using SPSS including what all the menus 
and windows are for. Try Help/Topics and look at the various topics, including SPSS at a glance. 
Help/Tutorial guides you through the basics of running SPSS - use it to supplement these notes. 
Just below the menu headings is the Tool bar, its buttons are shortcuts for many common tasks in 
SPSS rather than using the menus.

Pic 6: SPSS Data Editor detail, The Tool bar 

l ?j a | j j n,|r?| «] >r|ri d-i-lnl
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At the very bottom of the window you can see the Status bar. It shows the status of SPSS at the 
time, including the progress of any procedure and any special transformations in place (i.e. filters, 
splits or weights).

Pic 7: SPSS Data Editor detail, The Status bar
| SPSS Processor is ready i

The message SPSS Processor is ready is showing in our example, indicating that SPSS is waiting 
for something to do. The first space on the status bar is known as the information area. It provides a 
phrase and sometimes a pop up label to describe whatever the mouse is pointing to.

Pic 8: Information area detail with pop-up label

Place the mouse pointer over each button in the tool bar and watch the information 
area on the status bar at the bottom of the window as it changes.

Pic 9: The mouse over the Open File button and the Status bar

J 5J | I _J fc|G?| _J |r’-| □|-l.|n| «>|Q>|
1 : □ pen File

!B1 J[
m®

Data Editor grid in between.

Open File
]\Data View Vanable View /

SPSS Processor is ready

The contents of both the tool bar and the menus will change depending on what type of SPSS 
window you are looking at. Toolbars can be changed or new ones can be created in the Show 
Toolbars dialog box, opened by choosing View/Toolbars. Menus can be customised using the 
Menu Editor opened by choosing Utilities/Menu Editor.
Data can either be typed directly into the Data Editor’s Data View or an existing data file can be 
read in. The Data Editor looks like a spreadsheet, but has a much more rigid data structure.

SPSS lO-l 1.5 SPSS PC TOUR - 8



SPSS phrase book
CASE: Each row of the data editor represents a case. Cases are the units or individuals that 

make up the study, e.g. survey responses, products in an inventory, schools in a 
district, countries, plots in an agricultural experiment, etc.

VARIABLE: Each column of the data editor represents a variable. A variable is a
particular type of measurement for each case, e.g. it could be someone’s height, a 
code representing their social class or a recording of their opinion on some subject.

VARIABLE NAME: Above the data in the Data View, each variable has a variable
name. In Pic 4, you can see the variable names sex, race, region, happy, life and 
sibs above the data. Variable names can be up to eight characters in length and 
must start with a letter. There must be no spaces, full stops, apostrophes or other 
punctuation marks in the variable name.

VARIABLE LABEL: Variables can also have a variable label. It is a longer bit of text to 
describe the variable. SPSS uses the variable label in the output when the variable 
is used and you can see what the label is when you point the mouse at the head of 
the variable as in Pic 13.

VARIABLE VALUE: Each cell in the Data View is known as a variable value. It
represents the variable measurement for that particular case or row. These variable 
values can be numbers, numbers representing codes (nominal/ordinal) or text. SPSS 
assumes that the data is numeric unless it is told otherwise.

VALUE LABEL: Sometimes a piece of text called a value label is associated with each
variable value. You should see the data with the value labels switched off. They can 
be displayed by using the Value labels button situated second from the right on the 
tool bar.

Pic 10: Value labels button

Click the Value labels button on the tool bar to display the labels if you cannot 
see them.

Pic 11: Value labels button OFF ON

Click on Value Labels button again so you can see the labels.

SPSS 10-1 1.5 SPSS PC TOUR - 9



Pic 12: Survey data with value labels shown

^1991 U.S. General Social Survey.sav - SPSS Data Editor rare

Fi'e Fdit View Data Transform Analyze Graphs Utilities Window Help

g-ia|^l eg.
(SHXl

sex J racy region happy life sibs ——J

1 Female White North Ea

North Ea
Very Ha Exciting 1

22 Female White Pretty H Exciting

3 Male White North Ea Very Ha NAP 2
4 Female White North Ea NA Routine 2
5 Female Black North Ea Pretty H Exciting 4
6 Male Black North Ea Pretty H NAP 7 ■

7 Male Black North Ea 
Mi-irth Fo.... .

Very Ha Exciting 7
7'dR P o m a I o Rlorl/ Prof+v H..... .........MAP......

_LJ\n<,td View Variable View /

SPSS Processor is ready

Point at a variable name at the top of the variable column to see its variable label, 
as shown below in Pic 13.

Pic 13: Detail of Variable label for region in the Data Editor

| sex race Region ,__1__ hannw f_____ lifp sibs -A|

l|[ Female y White
x, , ■ |—• 11 1 ctcjldf i ul If to U HlltJd o Idle a  1 
North ta 1------vury-Tra------ cxcTring 1

______2l Female White North Ea Pretty H Exciting 2

You can change a variable value just by selecting it and typing in a new code. If Value Labels are 
switched on, you can also change it by choosing another label from the list of value labels or more 
tediously by typing in the whole value label exactly as it appears in the list.

Select a cell in the Data Editor and click on the small arrow beside it to see the list 
of labels defined for that variable.

JU If you change the data remember to return the data to its original state before 
going on or use the File /Open menu to open the original system file, clicking on No 
when it asks you to save changes to the data.

SPSS 10-11.5 SPSS PC t o u r  - 10



Si Running an analysis
Now to look at how you would run an analysis in SPSS. The Analyze menu contains the statistical 
analyses available. We will run through one procedure that deals with variables individually 
(univariate analysis) and another that deals for a tabulation using two variables together. From there 
you should be able to apply the same principles to other analyses.

Pic 15 & Pic 15a: Different sorts of statistical analysis available
for SPSS 10 and SPSS 11.5

Analyze Graphs Utilities Wim

Reports ►

Descriptive Statistics ►

Custom Tables ►

Compare Means >

General Linear Model ►

Correlate ►

Regression ►

Loglinear ►

Classify ►

Data Reduction ►

Scale ►

Nonparametric T ests ►

Tjme Series ►

Survival ►

Multiple Response ►

Missing Value Analysis...

Graphs Utilities Wine 

Reports ► I*
Descriptive Statistics ► js
Tables ► {

Compare Means ►
General Linear Model ►
Mixed Models ►
Correlate ►

Regression ►
Loglinear ►
Classify ►
Data Reduction ►
Scale ►

Nonparametric Tests ►
Time Series ►
Survival ►
Multiple Response ►
Missing Value Analysis...

Choose Analyze from the menus to see what is available.
An arrow beside a menu item indicates that it has a sub menu. Notice all the items in the Analyze 
menu have submenus. The list of menu items shown here is a fairly standard SPSS installation. 
Move the mouse over each arrow to see a list of the procedures available in each sub menu. Other 
items may appear on this menu depending on what modules are installed and whether the menus 
have been customised.

From the ^Analyze menu, choose Descriptive Statistics to see a list of the 
descriptive procedures.

These notes are intended to show you how to use SPSS, not to teach you statistics. 
There is a Statistics Coach in the Help menu to help you choose the correct analysis 
for your data. The coach is not very detailed so get take advantage on any statistics 
courses your department may run or get a good introductory statistics book.
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Frequencies
The Frequencies procedure generates summary tables of frequencies of each value for a variable. It 
can also be used to calculate summary statistics and charts for each variable individually as well.

Pic 16 & Pic 16a: Items from the Analyze/ Descriptive Statistics submenu 
for SPSS 10 and SPSS 11.5

Analyze Graphs Uti 

Re

Descriptive Statistics

Custom Tables 
Compare Means 

General Linear Model 
Correlate
Ronrof-finn

Window Help

Descriptive?...

Explore...

Cro.itab;
.-ycTrrrrg—i—-*

Excitina

Now chooseJKnalyze/Descriptive

Graphs Utilities Window Help

Reports
Descriptive Statistics

Tables

Compare Means 
General Linear Model 

Mixed Models

Statistics/Frequencies.

Frequencies,,:
Descriptives...
Explore...
Crosstabs.,.

Ratio...

► i’-f lrr-1

The Frequencies dialog box consists of two boxes of variable lists, below them are buttons to 
customise the procedure results and to the right of the lists are the five standard dialog buttons. To 
produce frequencies tables for a variable simply select it from the left hand list of all the variables 
in the data set and click on the arrow button to put it in the Variable(s): box.

Pic 17: Frequencies dialog box

. Frequencies

Variablels).

it/ Race of Responds

#> Region of the Unite

■ General Happiness _____ Reset
Is Life Exciting or D | < J|

iij> Number of Brothers Cancel

$> Number of Children Help
$> Age of Respondent i

1 I.U. , ----.iC

I? Display frequency fables

Statistic?... | Charts. | Format .

The three buttons along the bottom of the dialog box are for making additions or changes to the 
default output. Statistics... is used to add summary statistics for each variable in the Variable(s) 
list. Charts... is used to produce a graph for each variable in the Variable(s) list. You can choose 
between a bar chart, pie chart or histogram. Format... is used to change the format of the standard 
frequency table and the order objects are displayed in.

SPSS 10-11.5 SPSS PC t o u r  - 12



The five buttons down the right hand side of the box are common to most dialog boxes.
Clicking OK tells SPSS that the dialog box is complete and is to be acted on.
Paste will paste the underlying SPSS command into a syntax window - the SPSS commands

course deals with this in more detail.
Reset can be used to clear the dialog box of any selections made so you can start specifying 

the procedure from scratch.
Cancel is used to exit from the dialog box without running the procedure.
Help has information about the procedure and how to use the dialog box.

Above in Pic 17 the first variable in the list, Respondent’s Sex (gender), has been selected and is 
about to be put in the Variable(s): box using the arrow button.

Put a few categorical variables in the Variable(s) list, e.g. variables sex, race, 
region, happy and life were chosen in Pic 18.

Pic 18: Selecting variables for Frequencies1

Frequencies 0
#> Number of Brothers A 

Number of Children 

Age of Respondent

#> Highest Year of Scl 

Highest Year Schoi 

Highest Year Schoi 

Highest Year Schoi

#> R's Occupational P i
' .ItX l~l m C - .. m I l”' — I w  Illlllll

I** Display frequency tables

Variable(s)-

#> Respondent's Sex [sex 

Race of Respondent [r.

■z#> Region of the United St 

General Happiness [ha|
Is Life Exciting or Dull [

Statistics.. Charts. Format

Ok

Pa>te

Reset

Cancel

Help

Q

Double clicking on the variable will also transfer it into the Variable(s): box. Once there, if you 
decide not to use a variable select it in the Variable(s): list and move it back using the arrow button 
which should be pointing back to the original list or double click on it again.
Notice that the OK button (and Paste button) is active now in Pic 18 - as soon as SPSS has enough 
information to run a procedure it will activate the OK button. By comparison the OK button in Pic 
17 is inactive and looks faded or "greyed out". You could run the Frequencies procedure just now 
if you wanted to2. However we will look at the procedure in a bit more detail before we run it, just 
to heighten the sense of anticipation!

1 Each variable has a small icon beside it, showing # for a numeric variable (i.e. values are numbers). A string or text 

variable will show A< or A> for ones over 8 characters wide.

2 If you do run Frequencies at the moment, then choose Analyze/ Descriptive Statistics/ Frequencies from the menus 

to continue with the next section. Page 19 will tell you about the output.
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More information on procedures
Most Windows applications have a Help facility where you can get more information. It is usually 
accessible from the Help menu or by a Help button in SPSS dialog boxes. The Help button is 
“context sensitive”, i.e. in the Frequencies dialog box it points directly to the information about 
Frequencies in the Help system. Any time you lose track of what you are doing in a dialog box, use 
the Help button or the Help menu to find out more about where you are.

Click Help button and SPSS will tell you more about Frequencies.

Pic 19: Frequencies information in the Help window in SPSS 11.5

ffl • ' © 0

Hide Stop Refresh Options

Contents | Index j Search | Favorites j

- (o Base System j
+ Overview
:+ Getting Help
T Datafiles

Reading Excel Files .. 
if Reading Database Fi
± Text Wizard
+ Virtual Active File
± £ Distributed Analysis tv

Data Editor
+■ Data Preparation
if k Copy Data Properties
T Define Variable Ptopt
+ % Data Transformations
;+ £ File Handling and File
■T £ Restructuring Data
T Working with Output
:+■ £ Draft Viewer
if Sfe Pivot T ables
T Working with Comma

Qj Frequencies

j?) Frequencies Oats 
•;+: How to Obtain Fn
^5 Descriptives

Explore
Crosstabs 

& S rmmarize

Means
& OLAP Cubes 

O T Tests
e Paired-Samples T Te ’

frequencies

The Frequencies procedure provides statistics and graphical displays that are useful for ll 
describing many types of variables. For a first look at your data, the Frequencies 
procedure is a good place to start.

For a frequency report and bar chart, you can arrange the distinct values in ascending or i 
descending order or order the categories by their frequencies. The frequencies report can 
be suppressed when a variable has many distinct values. You can label charts with 
frequencies (the default) or percentages.

Example. What is the distribution of a company's customers by industry type? From the |j| 
output, you might learn that 37.5% of your customers are in government agencies, 24,9% 
in corporations, 28.1% in academic institutions, and 9.4% in the healthcare industry. For If 
continuous, quantitative data, such as sales revenue, you might learn that the average Jf 
product sale is $3,576 with a standard deviation of $1,078.

Statistics and plots. Frequency counts, percentages, cumulative percentages, mean, If 
median, mode, sum, standard deviation, variance, range, minimum and maximum values, ||
standard error of the mean, skewness and kurtosis (both with standard errors), quartiles, -jf 
user-specified percentiles, bar charts, pie charts, and histograms.

Show me

Related Topics

How to Obtain Frequency Table?

Frequencies Command Syntax

Descriptives

Descriptives pate Considerations

Explore Data Considerations

Summarize Data Considerations

Multiple Response Frequencies Data Considerations

Click Show me to open a tutorial about Frequencies or click a Related Topics link 
to find out more. In SPSS 10 the See Also button in the Help window will show 
you related topics.
Once you’ve finished reading, close the Help (and Tutorial) window and get back 
to SPSS and the Frequencies dialog box.

Context Sensitive Menus
A “context sensitive” menu can be activated for an object in Windows by selecting it and clicking 
on it with the right hand mouse button. The contents of menu will depend on the thing you selected, 
showing what you can do in that context. Normally one of the items is called “What’s This?” or 
“Properties” and it will tell you about the selected object.
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Information about variables
A variable information box is available via a context sensitive pop-up menu from SPSS dialog 
boxes. To do the following make sure the Frequencies dialog box is open.

Pic 20 & Pic 20a: Pop-up menu & choosing Variable Information
! Frequencies

Number w it >hh m ^J
Number of Children ] 

d£>Age of Respondent

Highest Year of Scl 

Highest Year Schoi
;$> Highest Year Scho«
$> Highest Year Scho>

$> R's Occupational P i

Variables).
Respondent's Sex [sex’ 
Race of Respondent [r.

$> Region of the United St 

$> General Happiness [haj

OK

fieset
■•.$/ ubnuidi ndppiriuss irid|

........................MillIs Life Exciting or I r
WWj Thr/?

What's This? 

Variable Information
Variable Information

Q

Click on one or two variables in either list using the right mouse button to display a 
pop-up menu similar to Pic 20. Choose Variable Information from the menu to 
see information about it

Pic 21 & Pic 2ia: Variable information for life variable & value labels

Notice as well as the rest of the variable definition there is a drop-down menu of defined value 
labels. If you click (left mouse click this time) on the dialog box in the background then the variable 
information will disappear. The other way you can get information about the variables is by 
selecting Variables... from the Utilities menu to open the Variables window.

ChooseJLJtilities/Variables... to see the Variables window.

Pic 22 <& Pic 22a: Choosing Utilities/Variables & Variables window

Utilities Window

File Info

Define Sets... 

Use Sets... 

Run Script-

Variable Information:

Menu Editor.

face
region
happy
hfe
sibs
childs
age
educ
paeduc
rnaeduc
speduc
prestg80
occcal80
lax
USIhti

sex
Label Respondent's Sex 
Type F1
Missing Values none 
Measuiement Level Ordinal

Value Labels
1 Male
2 Female

d

The Variables window contains the same sort of information in Pic 21, but in a window rather than 
a pop-up menu. The window can remain open in the background while you work elsewhere in 
SPSS. It can also be opened at practically anytime for reference in SPSS.
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^5 Click the Close button to close the Variables window, so the Frequencies 

dialog box is at the front
We will now look at some ways we can customise the Frequencies output using the Charts... and 
Format... buttons. Most of the statistics available via Statistics...button are more suitable for scale 
variables than the categorical ones we have chosen - so we will not bother with them at the 
moment.

CD If you 've lost the Frequencies dialog box, choose Analyze/ Descriptive Statistics/ 
Frequencies from the menus again and SPSS will bring it back to the front.

Just in case you have forgotten what it looks like, Pic 23 (a copy of Pic 18) shows the dialog box 
before we got diverted.

Pic 23: Showing the variables selected for Frequencies

Frequencies L*J
Number of Brothers 

#> Number of Children 
^>Age of Respondent 

#} Highest Year of Scl 
ip Highest Year Schoi 

ip> Highest Year Schoi 

ip> Highest Year Schoi 
ip R's Occupational P i

“I____ c... .1 r- i- —i

F? Display frequency tables

Ld

Variable!: J

<$> Respondent's Sex [sex' 

ip> Race of Respondent [r. 

ip Region of the United Si 
<i£> General Happiness [haj

or.

Reset

Cancel

He!p

Statistics | Charts | Format . [
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Frequencies: Charts, Specifying a bar chart
The Charts... button on the Frequencies dialog box opens the Frequencies: Charts dialog box 
where you can choose to produce graphical equivalents of the frequency tables. There are three 
sorts of chart available. Bar charts and Pie Charts are best for variables with few distinct values, 
i.e. categorical (nominal or ordinal) variables. Histograms are best for variables with lots of values 
measured on a scale, i.e. quantitative variables.

Click on theCharts... button to bring up the Frequencies: Charts box.

Pic 24: Frequencies: Charts dialog box

Fiequencies: Charts

Chart Type 

(* iNonei 

C Bar charts 

C Pie charts 

C Histograms

!■■■■■

Continue

Cancel

Help

i'~

Click on Bar Charts to produce bar charts with the tables.
Then click Continue to go back to the main Frequencies dialog box.

Make sure you selected Bar Charts and then clicked Continue. If you click Cancel or 
otherwise close the dialog box SPSS will close the Frequencies: Chart box without 
saving your selection and no chart will be specified.
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Frequencies Format
The Format... button opens the Frequencies: Format dialog box. It contains options to change the 
order of the Frequencies output or even suppress the output under certain conditions. We will 
change the setting and use Organize output by variables so we can see the frequency table for a 
variable beside its pie chart.

Click the Format... button and choose_Organize output by variables button. 
Click Continue to get back to the Frequencies dialog box to run it.

Pic 25: Selecting Organize output by variables

Frequencies: Format

Order hy

Ascending value; 

l'”" Descending values 

{~~ Ascending counts 

f” Descending counts

Multiole Variables
£"■ Compare variables

f* J^rganize output by variable?

I- Suppress tables with more 

than | categories

Continue

Cancel

Help

r*—rn^rtrnv'Tiriinrirrr.v iai.nc:.

E

Click the OK button in the Frequencies dialog box to run it.

Again make sure you click Continue after making your selection to save your selection.
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® The output viewer
As soon as you click OK you should see the SPSS Output viewer come to the front. And depending 
on how fast the computer is, you may see the status bar at the bottom change to 
Running FREQUENCIES.... before the results are written to the Output window. It should 
change back to SPSS Processor is ready as illustrated below when the procedure has finished.

Pic 26: A first view of Frequencies output

Output! - SPSS Viewei
File Edit View insert Format An

I I I I I
+■,£] Title 
Q Notes 
[fej Respondent ■ 

O Title 
fjj Statistic 

L®l Respon
CS Bar cha

| Race of Res 
© Title

Statistic j 
Race of©

Jjjl Bar cha 
j| Region of thSiji

® Titte 

Statistic <
.ijjl Region >■ 

fl'jl Bar cha ▼

►r

4 Frequencies

Respondent's Sex

Statistics

Respondent's Sex
N Valid 1517

Missing 0

SPSS Processor is ready

The SPSS Output Viewer will usually come to the front as soon as a statistical procedure is run. 
The Output window is split vertically into two panes. Above the split window, the menus have 
changed and different buttons are active on the tool bar to reflect the fact they are for use with 
different sort of window. The two “panes” of the viewer each have separate scroll bars which means 
you can scroll down the results or you can scroll through the outline or click on an icon to jump to 
that bit of the results.

The left side of the output window is the viewer outline, consisting of small icons 
representing the different parts of the SPSS output.
The right hand side contains the output itself.

In Pic 26 you can see the start of frequency output with the default summary statistics table for the 
first variable from our list, Respondent’s Sex. N Valid is the number of cases with valid values, i.e. 
there are 1517 where gender has been recorded and N Missing is the number of missing cases, 
where there is no valid value, none in this example. If we had used the Statistics... button to add 
more summary statistics they would appear in this table.
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Hiding the outline
The outline side of the output window can be easily hidden to give you a more space on the screen 
to inspect the results.

Place the mouse pointer over the divide between the two parts of the window. You 
should see the pointer change to a double-headed arrow.

Pic 27& Pic 27a: Double headed arrow & dragging to hide the Outline
. ............... ........................... (»■■■■,,l..>i,,i,i

:• Title 2T
... Notes r Z3

S...jEs] Respondents
\ \.....g) Title 4 Frequencies
j i.....Statistic

CO Respon

Click and drag the division over to the left most point and the outline will be hidden.

Pic 28: Results window with no outline

jj“s Outputl - SPSS Viewei
■’ File Edi> View Ircert Format Analyze Graph? Utilities Window Help

sifililRd 3d 51J UkUd il «J _J'
LJ I 1 I I -sl^lml

■+ Frequencies

Respondent's Sex

Statistics

Respondent's Sex
N Valid 1517

Missing 0

________ I
9 SPSS Processor is ready

Use the scroll bars to inspect the rest of the output.

SPSS 10-1 1.5 SPSS PC t o u r -20



Pic 29: Scrolling down - showing Frequency table for sex variable

$£ Outputl - SPSS Viewer EE
Tile Edit iiie'/j ln;ert Format Analyze Graphs Utilities Window Help

u?jojs]o| &J egj _J □|fc|c?| ®J *] _J

II II I I k’’|ct| a II I I I A. I -A. I I

iiSf

Respondent's Sex

Frequency Percent Valid Percent
Cumulative

Percent
Valid Male

Female
Total

636

881
1517

41.9

58.1
100.0

41.9

58.1
100.0

41.9

100.0

Respondent's Sex
1000 r

<L ±l
9 SPSS Procecsor i: ready

The outline can be seen again by clicking on the left hand side of the window and dragging the 
division bar towards the middle of the window, (mouse should be the double headed arrow again) 
This method can also be used to change the relative size of the panes by dragging the bar between 
them but just not all the way across.

Restore the outline by clicking on the left hand side of the window and dragging 
the division bar into the middle again.
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Using the outline
The outline can be used to organise the results you want to see to jump to a particular section of 
output. It is possible to hide items in the results by selecting it in the outline and “hiding” them.
Hide a selected icon by choosing View/Hide from the menus or double clicking on the outline icon. 
Click once to go to the output the icon represents and double click to hide the output.

Pic 30: Using the View menu to hide some output

Select an item from the outline and chooseJHHde from the View menu.

Pic 31: The result of hiding the Statistics output

Output! - SPSS Viewer
File Edit View Insert Format Analyze Graphs Utilities Window Help

GglBleiBd o»l E3| J rnb-.L&J cii p=j j1 

/H I Il u H 1

I Frequencies -
■ (|0 Title

Motes
jEj Respondent's Sex 

kjJ Ti tl© j

Ljgjl Respondent's Se| 

L',^ Bar chart
B[ Race of Respondent;

Frequencies

Respondent's Sex

Resp uni

Frequency | Pe

1

Double clicking on an icon in the outline will hide it, so the item is hidden in the results window 
and the icon looks “closed”. Double click on the icon again and it will open. Pic 32, the figure 
below shows the whole Frequencies output block closed, just by double clicking on the icon.
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Pic 32: Frequencies block icon closed

|7h Output! - SPSS Viewer
File Edit View Insert Format Analyze Graphs Utilities Window Help

^|g| ~i I a JnM id J _J

“2- □ D
Zi I A I J\

You can see in Pic 32 what the output icon representing an output block looks like when it's open, 
labelled Output, and when it is closed, the one labelled Frequencies. Also the small minus, -, and 
plus, +, buttons can be pushed to close or open an output block respectively.

About the Frequencies output
There are three different parts in Frequencies output, the summary statistics table, the frequency 
table itself and a chart if one has been specified.
The frequency table list the number and percentage of cases with each variable value, e.g. in Pic 33, 
the number in the sample who consider life dull was 41 and they were 2.7% of the whole sample 
and 4.2% of the people asked.

Pic 33: Frequency table for the life variable

Is Life Exciting or Dull

Frequency Percent Valid Percent
Cumulative

Percent
Valid Exciting 434 28.6 44.3 44.3

Routine 505 33.3 51.5 95.8
Dull 41 2.7 4.2 100.0
Total 980 64.6 100.0

Missing NAP 524 34.5
DK 8 .5
NA 5 .3
Total 537 35.4

Total 1517 100.0

U Look at the frequency tables for other variables in the Frequencies output and 
write down the number and percentage in the sample who:
1. lived in the North East region
2. were very happy at the time of the survey.
The charts are visual illustrations of the frequency table. In Pic 34 you can see the proportion of 
people who find life dull from the bar chart in relation to those who found life exciting and routine.
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Pic 34: Barchart for the life variable

Is Life Exciting or Dull
600 ----------------------------------------------------------------

Is Life Exciting or Dull

Notice that there are no bars representing missing values, the charts created with the Frequencies 
procedure only has the valid values in it.

Choosing Graphs/Bar... from the menus will permit you to create a chart showing the 
relative number of missing values. Look out for the chart tour coming soon which will 
have more on how to do this.
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Crosstabs
Frequencies deals with variables separately but Crosstabs displays two or more categorical 
variables in association with each other in a table. In fact it's called a crosstabulation and it’s in the 
same menu as Frequencies, so choose Analyze/ Descriptive Statistics/Crosstabs.... will open the 
Crosstabs dialog box.

Choose Analyze/ Descriptive Statistics/ Crosstabs.... 

Pic 35: Selecting Crosstabs
|7s Output! - SPSS Viewer
File Edit View kiiert Format Graphs Utilities Window Help

M|l a 1 d '
|| || | | ^ Custom Tables

Compare Means 

General Linear Model 

Mixed Models 

P nrrplate

•‘rw-’Tsnrrw"v:

6U0

Frequencies

Descriptives

Explore

Crosstabs-..

Ratio.

Select the General Happiness (happy) variable and put it in Row(s): 
Select the Is Life Exciting or Dull (life) variable put it in Column(s): 
Click the Display clustered bar charts option, as shown above.
Click OK to run the Crosstabs procedure.

Pic 36: Crosstabs dialog box

i Crosstabs

Respondent's Sex |

.$> Race of Responde 
■:$> Region of the Unite

Number of Brothers 
<$> Number of Children 

<$> Age of Respondent

Highest Year of Scl 

#> Highest Year Schoi

Highest Year Schoi 
Y- Highest Year Schoi 

A- R's Occupational P.
'$> Occupational Cater

R's Federal Income ▼ |

tDispiay clustered bar charts!

PH

Suppress tables

Exact...

Row(:l

General Happiness [he

Column[sl

OK

Paste

Reset

<$.■> Is Life Exciting or Dull [ *-'ance'

Layer 1 of 1

Help

BBI

Statistics . | Cell? [ Format.. j

□

u
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When it is finished you should be looking at the Output Viewer again. You can see in the outline 
that there are several blocks to the Crosstabs output including the table below in Pic 37 and the bar 
chart shown in Pic 38.

Pic 37: Crosstabs table

General Happiness * Is Life Exciting or Dull Crosstabulation

Count
Is Life Exciting or Dull

TotalExciting Routine Dull
General Very Happy 195 98 2 295
Happiness Pretty Happy 218 338 12 568

Not Too Happy 21 61 26 108
Total 434 497 40 971

Each valid value of the row variable will define a row and each valid value of the column variable 
will define a column of the table.

Pic 38: Crosstabs Clustered bar chart

Is Life Exciting or

IMExcitina

MMRoutine

IDull

General Happiness

Tables and charts can be customised to suit your own taste. Look out for the table 
tour and the chart tour coming soon!

SPSS 10-11.5 SPSS PC TOUR - 26



Leaving
To finish the SPSS session, selectJFile /Exitfrom the menus. 

Pic 39: Selecting Exit from the File menu
g* Outputl - SPSS Viewer

ISiSI Edit View Insert Format

Mew IIISIllll
Open
Open Database lliO

Read 1 ext Data

Close
Save Ctrl+S
Save As..
Save With Password...
Export...

Display Data Info...

Page Setup...
Print Preview
Print... Ctrl+P

Syvitch Server...

•HISK81
Send£4ail...
Recently Used Data
RecentlyUsedFiles ►

I n|.'lc?hal al I 
lOLid

Pretty Happy Not Too Happy

Is Life Exciting or

tMfexcitina

BBRoutine

■■Dull

Before SPSS shuts down you will be asked about saving the contents of each window in turn, in this 
case the output viewer window and the data window.

Pic 40: Warning to save the contents of the Output viewer

SPSS for Windows

f Save cot .tent; of output viewer to OutpuU 7 

11 %es No | Cancel [

For example in Pic 40, SPSS is asking whether to save the contents of the output viewer. The three 
buttons have similar functions whatever the type of window that is about to be closed.

Yes saves the contents to a file, either to a named file or a dialog box is opened to name 
a file where that window’s contents are to be stored.

No closes the window and none of the changes you have made during the session will 
be saved (unless you’ve used the save option in the file menu).

Cancel stops SPSS closing and leave the current window open.
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SPSS for Windows

Pic 41: Warning to save the contents of the data file
m

Save contend of data editor to H \SPSSwoil;\1'391 U S. General Social Survey.sav?

Cancel |

Click No for each of these dialog boxes, unless you wish to keep the data file or the 
output you made.
It is not essential to keep the contents of any of the windows created during this session - unless 
you want to keep a souvenir of the tour.
Each saved window can be opened up in SPSS, using the File /Open from the menus. Shortcuts for 
the most recently used files are available in the File menu under File/Recently Used Data and 
File/Recently Used Files. Choosing the shortcut from the menu will open the file in SPSS as long 
as it hasn’t been deleted in the mean time.
SPSS will associate a default file extension with different types of file. You can see these 
extensions in the drop down menu, Files of type: in Open File dialog box. The two most common 
extensions are . SAV and . SPO. SPSS data windows are saved to files with .SAV extensions and 
Output windows are given .SPO extensions.
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<D Information
This section contains some hopefully helpful nuggets of information. 
Things to do... including SPSS courses and on-line notes.

Places to visit... such as useful web sites

People to see... about getting help with SPSS and computers.

If any of the web links don't work try searching from the homepages for the 
University of Edinburgh at, http: //www .ed.ac.uk 
or Computing Services at, http: //www. ucs. ed. ac. uk/

Things to do...
Go on Computing Services courses
There are three SPSS courses offered once a term by Computing Services: 1195 Introduction to 
SPSS, 1196 Intermediate SPSS and 1203 SPSS commands.
These courses are primarily aimed at postgraduates and staff but all the details are at, 
http://www.ucs.ed.ac.uk/usd/iss/courses/

Go on courses in your department
If you are an undergraduate or taught postgraduate please check with your department (or course 
supervisor) - there maybe courses run for you there.

Look at SPSS notes on-line
There is a whole suite of on-line notes from the SPSS company in Adobe Acrobat format and the 
Statistical Analysis section will give you lots of examples of things you can do. Follow the link 
from the SPSS at Edinburgh web page at
http://www.ucs.ed.ac.uk/usd/stats/spss.html

Go on another tour
We hope that this will be the first of many tours, find out about them at
http://www.ucs.ed.ac.uk/usd/stats/spsstours.html
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1. Introduction
SPSS is a package developed originally for Social Scientists using large mainframe 
computers. Since then it has been refined and redeveloped for different types of architecture 
including Windows. It is an extensive package with facilities for data entry, data 
manipulation and statistical analysis in a graphical environment. It has modules for survey 
analysis, graphical display and time series. The package has been considerably improved to 
include logistic regression and repeated measures analysis and much more beyond the scope 
of this tutorial.

2. Getting Started
This tutorial document assumes that you have a basic knowledge of Windows. The 
Information Technology Services (ITS) provide introductory courses and documents for this 
purpose. This tutorial is based on the default installation of the software at Reading where 
your Unix home directory will be available to you as the N:\ drive and shown on the desk­
top in the Windows environment as My Documents. Access the package from the Start 
menu and select Statistics and then SPSS 12 for Windows. Ignore, by selecting OK, any 
error messages that may appear on the screen until you see Figure 1. Select the option Don’t 
show this dialog in the future and this dialogue-box will not appear again. You can then 
remove the screen by selecting the Cancel button.

Figure 1

SPSS for Windows

What would you like to do? 

M C Run the tutorial 

C Type in data

r" Run an existing query

Create new guery using Database Wizard

f* Open an existing data source

More Files..

Tr C Open another type of file

More Files...

P Don't show this dialog in the future

} OK I Cancel
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Wait until Figure 2 then appears on the screen. [For information - to exit SPSS, click on the 
File option on the menu bar and choose Exit and confirm your intention]

3. Default SPSS Windows
The default image, which should be visible, is shown in Figure 2. The main window, 
Untitled - SPSS Data Editor, with the Data View tab highlighted allows numeric data entry 
direct into the spreadsheet using the default options. If you are not in this view then select 
the correct Tab at the bottom of the screen before proceeding further. The Variable View 
tab will be discussed later in the tutorial for inputting of non-numeric data and other uses. 
Maximize this window image if you prefer.

Figure 2
^1 Untitled - SPSS Data Editor

File Edit View Data Transform Analyse Graphs Utilities Window {Help

4. Notation
In the sections that follow, the actions you must perform are shown in bold, as too are the 
default values chosen by SPSS 12. Italic is used to denote items whose names/values you 
may choose. It is preferred that variable names start with a letter and are kept as short and 
simple as possible.

For information:
A sequence of actions using the drop-down menus will be denoted by For example, 
Data->Insert Variable... would mean "Click-left on the Data option on the drop-down 
menu and select the option Insert Variable... (by clicking-left again)".
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5. Data Entry
If SPSS 12 has been set up correctly the first empty column in the first row will be outlined 
in the Untitled - SPSS Data Editor window. Enter the following three columns of data into 
the spreadsheet.

11 110 22
15 129 250
104 90 195
168 102 177
60 145 297
125 86 186
111 109 188

By default the names given to these three columns are varOOOOl, var00002 and var00003. 
Each row of this data represents a farm number, the number of trees on that farm and the 
total yield of apples (in unspecified units) from each of the farms. It would, therefore, be 
more useful to have suitable names for each column.

Move to the Variable View window (click-left on the tab at the bottom of the window) to see 
Figure 3 and replace the default names by those suggested above in the Name column. 
Move back to the Data View window to see Figure 4. Do not worry about the contents of the 
other columns, shown in Variable View, they will be discussed as the need arises.

Figure 3

rile Edit y.4.7 Rnt<> Transform finalyza graphs UtiStios ygndow fcidp

«|.-| '■ J MC?|

[ Type J Width

•,ld cteini!

| Columns | Align Measure 1Name Decimal? | Label J Values | Missing

I [Numeric ;8 2 [None None 18 Right Scale '
1BB2 trees •Numeric :8 2 i [None (None fe Right Scale
11(13 apples... i Numeric [8 2 I None Nono 8 Right Scale

Figure 4
sPlS0.1.1 l>lit

fcdt Vew Cista Tramrwm Analyze Greph$ Uhbttes Window He'p

6. Saving Your Work
Although entering the data in Section 5 did not take too long it is always wise to save any 
work you have done. Saving your work should be a frequent operation whenever you use a 
PC.
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Exercise 1

Several types of files, subsets of variables, or commands can be saved. Here you will be 
creating a SPSS Save file (.sav) which will create a file in compressed form containing the 
complete set of data, names and formats.
Choose File-»Save As... from the main drop-down menu. The :Save Data As dialogue 
box appears (as shown in Figure 5). If necessary, choose the correct folder 
(My Documents\SPSS__Tut), then type a relevant filename e.g. apples in the File name 
box. [Note that the default file extension is given as .s«v] Click on Save and the data will 
be saved.
The dialogue box will close automatically after the file has been saved.

Figure 5

Save Data As

Save ]n [TT My Document
“““I | „ JL I I MMM IJ £3] £4] er) itnn E^l

___| Adobe ■_j

1 Advantage ' ' (Bit;

'v’l All-in-one □l

' 1 My eBooks ■ w Ba

_U My IML Workshop Files

') My Library □

fj My Music Q;

.d................ ............ 1 d
K eeping 3 of 3 variables Variables |

File name: | Save |

Save as type: jSPSS (Wav) J Paste

Vst'rite variable nomev lu spreadsheet
Cancel

f” Syve value lubulv wl lu-re defined instead uf data values

at

7. Reading in a SAVED data set
As we are dealing with a very small set of data it is a good time to learn how to read in a 
previously saved SPSS data set. Follow Exercise 2 and exit from SPSS, check that the file 
exists and then restart the program and retrieve the saved file you have just created.

If you have SPSS 12 installed on your personal PC you would be able to open the file 
My Documents\SPSS_Tut\opp/es.s«v from within the file manager. However, this facility 
has been removed from the centrally controlled PC labs on campus.
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Exercise 2

• Choose File->Exit from the main menu. Using any method you know (ie look at the 
contents of the folder My Documents\SPSS_Tut on the desktop) check the file 
apples.sav exists. If necessary you may need to repeat the tutorial from the beginning.

• Invoke the package again and wait for the software to be reloaded, (described in 
Section 2)

• Select File-»Open-»Data... from the main menu bar. This will show the Open File 
dialogue box similar to Figure 6. Check you are looking at the correct folder and 
filename My Documents\SPSS_Tut\ap/?Zc<s..sav and select Open

» Check that the apples.sav - SPSS Data Viewer is as shown in Figure 4.

8. Listing the Data
One of the first things that you should always do with the values you have input is confirm 
that the program will be working on the data values exactly as you intended. You can easily 
make a mistake by typing 100 in place of 1.00 and this would make your results very 
strange. As your data is in a spreadsheet you can do this by checking the values straight from 
the screen. Flowever, you may wish to create a paper listing and take it away with you to 
check. Follow through the next exercise in order to list and check your data.

Exercise 3

From the main menu bar choose Analyze—/Reports—/Case Summaries to produce the 
dialogue-box shown in Figure 7.
Highlight the word apples from the selection on the left-hand side and then click on the 
I k j
L. —J button to select the variable as required to be listed. Repeat for farm and trees.
Click on the OK button. The maximised Outputl - SPSS Viewer window will become 
visible. Scroll up and down through it to check that it looks like Figure 8. Note that the 
data is listed in the order in which you selected the variables e.g. alphabetic. This window 
could then be printed - do not attempt this now.
Correct any mistakes if necessary, and re-save the data file using File->Save. This will 
automatically overwrite the file My Documents\SPSS Tut\flpp/gs.5'av.
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! Sumniiiiize Cases

farm

trees

Figure 7

Variable?

Grouping Variable(s):

2d

Reset

Cancel

Help

□

□

^■1

P Display cases

P brnir case: to first pf.jo 

p Show only valid cases 

F"* Show case numbers
Statistics.. | Options 

Figure 8

AS QutjUll t iPSS Vll‘Wl‘1

Filo Wit View Insert Format ftnalyco graphs Utilities Window Ijolp

ad SJ d MhlAl J&j 2J 
d-d J ’x|Pl3li

Output
-} ■ ■ {fe| Summarize 

*>□ Title
Notes
Case Processing Surnrnt 

UgB Case Summaries

4 Summarize

Case Processing Summary1

Cases
Included Excluded Total

N Percent N Percent N Percent
APPLES 7 100.0% 0 .0% 7 100.0%
FARM 7 100.0% 0 .0% 7 100.0%
TREES 7 100.0% 0 .0% 7 100.0%

a. Limited to first 100 cases.

Case Summaries9

APPLES FARM TREES
1 22.00 11.00 110.00
2 250.00 15.00 129.00
3 195.00 104.00 90.00
4 177.00 168.00 102.00
5 297.00 60.00 145.00
6 186.00 125.00 86.00
7 188.00 111.00 109.00
Total N 7 7 7

a. Limited to first 100 cases.

(SPSS Processor is ready
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9. Exploring the Data
There are several techniques for helping you to summarise your data. Checking data means 
or plotting appropriate pairs of variables quickly give you an image of the spread of the data. 
Both of these checks can be made by following Exercises 4 & 5.

Exercise 4

1. Data Means:
Choose the Analyze->Descriptive Statistics-»Descriptives menu to get a dialogue-box as 
shown in to Figure 9 below. Select the variables apples and trees in the same way as you 
did in the previous exercise and then click on OK. Check the contents of the Outputl - 
SPSS Viewer window against Figure 10. The summary statistics produced are the default 
actions of the command but as you will see from the syntax (command language) printed in 
Figure 33 the underlying command is getting quite complex.

r Save standardized values as variables

Figure 9

OK

Paste

Cancel

Help

xj

Options .

Figure 10
IPSOutputl 51*55 Viewer -D1*J
File Edit View Insert Format Analyze Graphs Utilities Window Help

; <s |h w b4 5*151 -.1
±hJ *1 -IMJ jisljs] 1

(kJ Output
i-i -.gj summarize

t] ™e 
B Notes
i Case Processing Surnrm 

.....i,$ Case Summaries
i-i ■ gj Descriptives 

4*£] ™e
.... @ Notes
.... Descriptive Statistics

J•> Descriptives

Descriptive Statistics

N Minimum Maximum Mean SW, Deviation
APPLES
TREES
Valid N (listwise)

7
7
7

22.00
86.00

297.00
145.00

187.8571
110.1429

85.10274
20.92390

<SP5S Processor is ready

Exercise 5 

2. Scatterplots:
From the main menu select Graphs-»Scatter ... This will produce a further dialogue-box as 
shown in Figure 11. Select the Simple plot and click on the Define button to produce 
Figure 12. Select apples as the Y-axis and trees as the X-axis using the method in 
Exercise 3 and then click on OK. The Outputl - SPSS Viewer window now contains this 
simple scatterplot (as shown in Figure 13).
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Figure 11

xjScatterplot

/A Simple

Overlay
*

Matrix

3-D

[..Definej

Cancel

Help

I” Use chart specifications horn1

Bill

Figure 12

i—, y.A«*................... o k I

r—iLd l>
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Cancel [

Help |

fi Outputl SP« Viewer

Figure 13

Fife Fiji View Dab) tren^Oim Insert Format Andyze S-PLU5 Gr.splu Window He%>

tfIMlalal se) sQ Bki~&f<a>~l jJ ■............ ......
..±JjdJdd.2laiJiJ

MllAS
[£■] CUtpCt

{&} Summarize

STille 
Notes

■ ■ ■ i.^ Case Processing Summary 
Case Summaries

-i (g Descriptives 
■■ • Sg) Idle 

' @ Notes

, Descriptive Statistics
S- (&| Graph 

; . « Title

l£“] Notes
• Scatter ot apples tress

Graph

L J r

■S^B

label Cases by:

lilies... [ Options...

73

1)111111
,0.00 30.00 100.00 110.00 ,20.00 130.00 140.00 150,00

tress

>5W$ Processor bread/

j/j

10. Saving Results
It is possible to print the contents of the Outputl - SPSS Viewer window directly but now 
that the facility for draft printing has been withdrawn in the public PC labs this exercise 
shows how to save your final results to be printed out at a later stage. Try the following 
exercise to save the contents of the Outputl - SPSS Viewer window so that you can print it 
out in your own department after this tutorial. [Another method of saving results would be to 
Cut and Paste the relevant sections into a Word document - you may find this easier when 
doing your own analysis]
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Exercise 6

If necessary, move into the Outputl - SPSS Viewer window and click in it. Select 
File->Save As which will give the dialogue-box similar to that shown in Figure 14. 
Confirm that your folder My Documents\SPSS_Tut is selected and then supply a suitable 
File name such as apples. [Note that the default file extension is given as .spo] Click on 
Save and the complete contents of the output window will be saved and the default window 
name changed to My Documents\SPSS_Tut\flpp/es.spo. It is possible to save the graphs 
separately in a special format that can be imported into a Word Processor, such as Word 
2000, however, for most reports this quality is sufficient.

Exit from SPSS 12 [File—>Exit] but you do not need to save the contents of any other 
window.

Figure 14 Figure 15
Openhh*

Save in, |’.J SPSS_TUT f£] Q O’ Look in: p.) SPSS_TUT
.’J*J

23 *■ © cj &
papules.spa

Fite rjame: J|
Fites of type: JViewei document (\spo) "3

| Open

Cancel

File name. ppp'es 

Save as type- Jjjjj

Exercise 7

To print the output file My Documents\SPSS_Tut\«/jpZex.spo, once saved, you can read it 
back into SPSS 12 from the File-»Open-»Output... menu and choose the correct file as 
shown in Figure 15. Try it now before going on to the next set of data.

Do not attempt to print it in the tutorial PC lab.

Exit from SPSS 12 [File-»Exit] so that you have a clean session for the start of the next 
exercise.

From now on the resulting output from exercises and basic dialogue-boxes 
will not be shown unless further options are selected and additional screens 
appear. Ask the tutor if you are not sure but be adventurous at this stage. 
Make mistakes now on a small data set - do not wait until you have entered 
your data containing 126 variables and 3452 observations!
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11. Reading Data From A Separate File
A data set that you wish to analyse may have been entered using a text editor, a database or 
into another spreadsheet facility. This example assumes that the data, with which you have 
been supplied, in My Documents\SPSS_Tut\scZrooZ.</«/ is in an ASCII (plain text) file 
created using an editor such as Notepad. There are many methods to read (or input) data into 
SPSS 12 but for the purposes of this session, it is assumed that data values are separated by 
one or more spaces but that character values have no spaces between them. This is called 
Freefiekl data.

Other forms of data entry are not considered in this tutorial. For example, Excel spreadsheets 
can be opened directly into SPSS 12 and you may prefer to explore this facility in your own 
time. For help on inputting complicated formatted data please come to the Statistical 
Computing Advisory Service where someone should be able to help you

The four columns of data represent:-

School name of school
Quest the number of the question asked - yes/no answers only
Number the number of responses to that question
Correct the number of “yes” responses to that question

The data file (without the column/variable names) is shown here:-

School
Willink
Willink
Willink
Willink
Willink
Maiden
Maiden
Maiden
Maiden
Maiden
Stonely
Stonely
Stonely
Stonely
Crossley
Crossley
Crossley
Crossley
Crossley

Quest Number Correct

2
3
4
5

2
3
4
5

2
3
4
5

10
15
12
10
20
13
12
15
27
23
5
15
7
12
30
30
30
30
30

7
8 
11 
9
14 
8 
9 
13 
22 
19 
4 
12 
7 
11 
25
15 
28 
27 
29

2
3
4

Do not type this into the spreadsheet. Follow the next exercise to input the data.
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Exercise 8

Begin by invoking SPSS 12 again, and access the File-»Read Text data... menu selecting 
the data set My Documents\SPSS_Tut\xcAuo/.dat. You will need to change the option of 
Files of type to Data (*.dat) and choose the file before selecting Open to get Figure 16.

Follow the instructions listed here to read in this set of data.
• Confirm that the option Does your text fde match a predefined format? is set to No.
• Click on Next button to get Figure 17.
• For the question How are your variables arranged? select Fixed width
• Are variable names included at the top of your file? select No
• Click on Next button to get Figure 18.
• Leave the options as they are set and click on Next button to get Figure 19.
• Scroll down the data shown and you will notice that the last letter of Crossley school 

goes past the end of field marker (t). Move this marker by clicking on the upright line 
and dragging it one column to the right. Click on Next to get Figure 20.

• Highlight the first column VI (as demonstrated in Figure 21) by clicking in the grey box 
above the column. Under the option Variable name give the name school in the 
Variable name box and confirm String within the Data format box.

• Repeat this process with the next variable quest as a Numeric variable
• Again with variable number (also confirm that Numeric is in the Data format box) 

and then finally the last variable correct (again Numeric).
• Click on Next button to get Figure 22.
• Check that your screen is the same as Figure 22 and then click on Finish button.
• The Variable View window should contain the information shown in Figure 23 (check 

that school is a String type and all the others are Numeric) and the Data View window 
should contain the 19 observations of the data set.

Figure 17Figure 16
h*»l liiipMil Y/r.iid Ma p ? of (i

I . . . . i .. .I . . , .1 .-

Uillinft
jJiHiuk

1
2

10 7
8

3 Uxilink 3 12 11
4 Uillinfc ! 10 9 j

| Help< P > »
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Figure 19Figure 18

Figure 20
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VI 1 « I V3 1 «« 1
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Wftnk : 4 i io j 9 ;
Wlilink ; 5 i 20 \ t4 htlBSlOliSsSiSii

J__\22_J 1.... f hh" I C el I Help [

I I K'lJ >11 f . v I U'Itf'M-.r<> »|rj<tlli >' H)l(j|( VI.

I I Mvrli > i .el ■• F » ' I ,k.H» Je « Jpr.,. n
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5
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IS. 1
28
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J
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12. Transformations and Calculations on Data
Using the data set just input, the percentage of “yes” answers for each question e.g.
[ number of correct answers ------------------ ---------------- :
( total number of responses J

400 might be required. Exercise 9 demonstrates this facility

as an example of manipulation of data values. Many other calculations and transformations 
are possible but can be explored in your own time.

Exercise 9

Select Transform-»Compute from the main menu to get the Compute Variable box 
shown in Figure 24. Complete the dialogue-box in the following way:
• Enter the name of the new variable percent in the Target Variable box
• Type in the expression (correct/number)*100 in the Numeric Expression box.
• Click on OK and return to the Untitled - SPSS Data Editor window and check that one 

or two observations, of the new variable percent, have been calculated correctly.
• Calculate the number of "incorrect" (or not "yes") answers to show you understand how 

to use this facility.

1 Compute Variable
[arget Variable:

Figure 24

Numeric Expression

BBBB

Al .L'huCll

quest 
j£> number 

'#? correct

13
*1 5[6

Function?

_j = I ^=1 j Jj l I J. 
Mil 0 I

ABS(numexpr)
ANY(test,value, value,...
ARSIN(numexpr)
ARTAN(numexpr)
CDFNORM(zvalue)
CDF.BERNOULLI(q.p)

□

|

_ |

1

~| 1 1 | Beset | Cancel | Help |

13. Creating Subgroups of Data
If you want to repeat an analysis for each subset of observations, it is possible to split the file 
into the groups required and then do the analysis automatically on each group. To 
demonstrate this facility try the following exercise to consider the mean of the percentage 
data for all schools together and then for each school individually.
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Exercise 10

Calculate the overall means of the variables number, correct and percent (use Exercise 4 as 
a guide). Then split the file into the four different schools as follows:
♦ From the main menu select Data-»Split File to get Figure 25.
♦ Select the option Organise output by groups.
♦ Select the variable school and move it into the Groups Based on: box. Your screen 

should now look like Figure 25.
♦ Click on OK as usual. Notice that the data in the Untitled - SPSS Data Editor window 

has been sorted by school and that it lists the c r o ss l e y  school first.
♦ Repeat the calculations with the same variables and see that four separate mean values 

(one for each school) have been calculated for each variable.

Figure 25

«Split File

#> quest 

#> number 

#5 correct

percent

Analyze all cases, do not create groups 

F* Compare groups 

(* Organize output by groups

groups Based on

OK

Pa^te
Re-et

Cancel

Help

<• Sort the file by grouping variables 

r File is already sorted

Furrent Status Analysis by groups is oft

Exercise 11

Be aware that the data file is considered to be split into the groups for any following analysis 
so complete the next exercise to show how to remove the grouping indicator.
Very simply, follow the previous exercise but this time select the option

Analyze all cases, do not create groups.

Notice that the box entitled Groups Based on: has become dimmed. Click on OK. You 
need to be aware of the status of the data set that you are analysing so that you always work 
with the data intended.

Exit from SPSS 12 [File-»Exit] but again you do not need to save the contents of any 
window.



16

14. Data Summary
If survey data are being analysed, almost the first thing that is required is to display the data 
in tabular form. This has the added bonus of being a way of checking categorical data. The 
following exercises demonstrate methods of tabulating data.

A file, My Documents\SPSS__Tut\x«rv.r/at, has been provided for you containing data in the 
following form:

Variable Options Type Suggested Variable 
Name

Age Numeric
Level of Education N (None)

0 (O-level)
A (A-Level)
D (Degree)
P (Postgraduate)

String educ

Years in Work Numeric work
Work Place String Place
Marital Status S (Single)

M (Married)
D (Divorced)
W (Widowed)

String status

Sex M (Male)
F (Female)

String Sex

Number of Children Numeric Child
Smoker Yes:No String Smoke
Drinks Alcohol

Exercise 12

Yes:No , String Drink

Using the instructions in Exercise 8 read the data file My Documents\SPSS_Tut\s«rv.4fl/ 
into SPSS 12. Modify the variable break (Figure 19) between the last two columns {smoke 
and drink) as necessary and then remove the vertical line from within the drink column. 
The end of row automatically marks the end of the value.
When complete, check the Untitled - SPSS Data Editor window for any obvious errors 
and if necessary, ask the tutor for help. Check the Variable View window against Figure 26 
with particular reference to the Type information. The value in the Width column will 
depend on whether you have moved a vertical line.
Before proceeding further save the data window (Exercise 1) for future use, as 
My Documents\SPSS_Tut\zMy5«rv.s«v.

[If you are having problems at this stage and are struggling with time, you have been 
supplied with a previously prepared SPSS file called My Documents\SPSS_Tut\x«rv.sflv. 
Follow Exercise 2 to bring it into the Untitled - SPSS Data Editor window and continue 
with the next exercise.]



17

Figure 26
I (iTO Unlilled - SPSS Data Editor BBSS!

File Edit View Data Transform Analyse graphs glihties Window Help

.si EJ| -dt ,|; .■-Ir?| 1 It’11.1-tll d |'d»|
IlilMISgli

Mi mg Columns *1Name T?re | Width Decimals Label

■1 age Numeric !3 2 None None 8 Rigi j
educ String I3 0 None None 3 Left

3 work Numeric 15 2 None None 8 RiqiS
4 place String fg 0 None None 9 Left
5 status String 14 0 None None 4 Left
6 sex String ........k............................ 0 None None 4

Leftjjjj

child Numeric 16 2 None None 8 Rigl
8 smoke String 0 None None 6 L-eftl

9 drink String =6 n None None 6 Left
.........i...................................

Exercise 13

This exercise demonstrates simple one-way frequency tables. Select Analyze—»Descriptive 
Statistics-»Frequencies.... Select variable sex to demonstrate Figure 27 then click on OK. 
Examine the output. Repeat with other variables as you wish, removing the pre\ ions

selection by highlighting the variable name in the Variable(s): box and click on the 
button. If you have more time select the Statistics and Charts buttons and try the options 
for more descriptive statistics and bar charts.

Exercise 14

Crosstabulations can be produce using a different menu selection. This time choose 
Analyze->Descriptive Statistics-»Crosstabs... to produce Figure 28. Select a variable to 
appear in the row dimension and another to appear in the column dimension e.g. smoke and 
drink. Click on OK and examine the output again. Can you interpret the results OK? Try 
adding the Expected values and the Row percentages to the Cells and calculate the Chi- 
square (look at Statistics).

i Frequencies

age A
Aj, fiJi|C

juik
Aj place

A< djhjs
ch.ld

A< ?fnol e

A< dunk

i? Display frequency tables

a

Figure 27

OK

Paste [

I.- -t j

Cancel I

Statistics . | Charts.. | format.. |

Figure 28
i Crossbills

•f , ? Bill
'<1

A< p i ti- |

place fi'*Al

A< I I MSI
<oiumnw
WflHi CdNU‘l |

A^ r
* tfr-lp |

1 drat1 ut1 |

■

1“ Display clustered jjat charts

Ejjacl, [ Statistics.,) Calls... [ format |
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15. Statistical Analysis - Regression
SPSS contains many facilities to perform statistical analyses. All should be used initially 
under the guidance of a statistician as there are many ways of producing the wrong analysis.

The following exercise uses LINEAR REGRESSION to perform simple regressions. 

Exercise 15

The SPSS 12 file My Documents\SPSS_Tut\rega««Z.5flv has been prepared for you so 
open up this data file into the Untitled - SPSS Data Editor window saving the Output 
window if you want to keep a copy of the previous exercises.
The new data set comprises 20 independent observations on variables U, W, X, Y and Z. 
Note: U represents the regulated Underfloor heating temperature (-10 to 10 degrees)

IV represents the amount of ILater vapour
X represents the time (in minutes) between readings 
Y represents the Field of the plant 
Z represents an unknown chemical compound.

Using the plotting command (see Exercise 5) investigate the relationship between the 
dependent variable, Y , and one of the independent variables, X. (To see how the yield of 
the plant varies with time).
Can you suggest a relationship between X and Y? Variable Y looks as if it is increasing 
linearly with each observation, so a simple linear regression should give the best fit. From 
the main drop-down menu select Analyze-»Regression-»Linear and choose Y as the 
dependent and X as the independent variables (see Figure 29). Click on OK.
Look at the output but do not worry if you are unable to interpret this or any other statistical 
output. This tutorial is showing you the methods that can be used in SPSS when necessary 
and does not attempt to teach you statistical techniques.

|_|

Figure 29

Dependent

________ J Bloch 1 ol 1 Next
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71

Method [Filter ~^| 
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o

B ;.............  ..........

Statistic; I P]ots I Save I Options.

MS

OK

Paste

Reset

Cancel

Help
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The following exercise uses CURVE ESTIMATION to perform more complex regressions. 

Exercise 16

Repeat the plot between another pair of variables Z and X. By eye, it does not look as if a 
linear regression would be the best fit between these variables Z and X but you can try it 
anyway. This time you will use a different method.
Select Analyze-»Regression-H>Curve Estimation... and choose Z and X as appropriate 
(see Figure 30). Using all the default selections, fit the curve. Notice that a plot is 
automatically prepared with both the observed data and the fitted linear regression being 
plotted together. It does not appear to be a good fit, so repeat this part of the exercise 
selecting the Quadratic and then finally the Cubic options in the the Models selection box. 
This is also known as “polynomial regression”.

Where is the observed data on the cubic plot?

Repeat the previous exercise (Exercise 15) to show a straightforward multiple regression 
using "unrelated" explanatory variables. Select IV as the dependent variable and U and Was 
the independent variables. It is not possible to show this on a two-dimensional graph.

i Curve Estimation LS

•?? u
'%> w

jependentfs)
OK

:i <#> z
Paste

Independent 
(• Variable

Reset

Cancel

' Li] I*
Time

Case Label.

n

Help
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f*7 Plot models

Model’
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r Logarithmic 1“ Cubic 

I- Inverse U Power

r Quadratic l~ Compound I- Growth

' 1"" S r Exponential

l~ Logistic

1 Disphi; AN OVA table Save
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Exercise 17

When regression analysis has been performed it is usual to want to save the predicted (or 
fitted) values and residuals and plot them against each other to check that they are randomly 
scattered about zero. SPSS 12 allows you to both save and plot at the same time.
Select Analyze-»Regression-»Linear... and choose the simple regression of Y on X. This 
time, however, click on the Save button and select Standardised Predicted Values and 
Standardised Residuals.

Click on Continue to return to the previous screen and then click on Plots.

Choose *ZPRED as the X-variable and *ZRESID as the Y-variable. Click on Continue and 
then OK. Look at the Outputl - SPSS Viewer and Reganal - SPSS Data Editor windows 
to see the results. Did you achieve Figure 31?

What new columns are created?

Figure 31

Scatterplot

Dependent Variable: y

-1 o 1

Regression Standardized Predicted Value
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16. Analysis of Variance
SPSS also has many commands to perform analysis of variance dependent on your data 
collection. This exercise demonstrates a simple analysis of variance of a balanced designed 
experiment.

Exercise 18

Another fde has been created called My Documents\SPSS_Tut\Z>a/aov.xav. Open this into 
the SPSS Data Editor window (saving the previous results if required) and look at the data. 
The file contains information on the yield of tomatoes from an agricultural experiment 
which was set out in 3 blocks {blk ) with 2 treatments {side with 2 levels and strain with 4 
levels). Analyse the data in the following way assuming that strain is randomised across 
all plots in each block - a factorial randomised block design.
Select Analyze-»General Linear Model-»Univariate and in the resulting window select 
yield as the dependent variable and then blk, side and strain as the fixed factors to be 
defined. This time, rather than run the commands automatically (using OK), Paste the 
commands into the Syntaxl - SPSS Syntax Editor window, as shown in Figure 32, where 
you can see the default Design sub-command as follows:

DESIGN blk side strain blk*side blk*strain side*strain blk*side*strain .

Now run the commands shown in this window by clicking on Run-»Current [or use Ctrl- 
R] and look at the results in the Outputl - SPSS Viewer window.

The experiment we are looking at was initially designed as a split-plot, in which each strain 
was randomised within each main plot {side). To analyse it as a split-plot, return to the 
Syntaxl - SPSS Syntax Editor window and edit the Design sub-command to the one 
below:

DESIGN blk side blk*side strain side*strain.

Re-run the syntax.

In order to display the means for side and strain, return to the Univariate dialogue-box (via 
Analyze-^General Linear Model-»Univariate menu), select the Options button and 
choose the factors required, and continue as before defining the appropriate (second) design. 
This time, highlight and run just this Selection of the Syntaxl - SPSS Syntax editor 
window.
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Figure 32

Syntaxl - SPSS Syntax Editor
File Edit View /jnalyze Graphs Utilities Run Window Help

Ot C? #4 ► r=i| ■

} UNIANOVA

yield BY blk side strain 
/METHOD = SSTYPE(3)
/INTERCEPT = INCLUDE 
/CRITERIA = ALPHA(.O5)
/DESIGN = blk side strain blk*side blk*strain side*strain blk*side*strain . j

» SPSS Processor is ready

17. Saving Command Syntax
A copy of all of the syntax (SPSS command language) used to produce the analysis required 
is automatically saved in a fde called s ps s . jn l . However, this file is usually overwritten 
every time SPSS is invoked.

It is also possible to direct certain parts of the syntax to a separate file for future reference, 
for example, you may want to repeat the exact analysis on a new set of data containing the 
same variables etc. As shown in the previous exercise there is a Paste button available. 
Having run a particular dialogue-box (e.g. Descriptive Statistics) and decided that this 
would be needed for a subsequent data set you can return to this box and select Paste. A new 
icon will appear on the taskbar which if you open it should contain similar information to that 
shown in Figure 33.

Figure 33

gj Syntaxl - SPSS Syntax Editor grr.i
File Edit View Analyze graphs Utilities Run V/indw Help

I'M rax 0? | ► 1 'Ol i?:l|
DESCRIPTIVES
VARIABLES=apples trees 
/STATISTICS=MEAN STDDEV MIN MAX.

* SPSS Procesror L ready



23

It is possible to save the contents of the Syntaxl - SPSS Syntax Editor window for use at a 
future date. If you want to save any of the command syntax that you have pasted into the 
window before exiting then move into the Syntaxl - SPSS Syntax Editor window and click 
on File-»Save As..., Give a suitable name to the file which is given the default extension of 
.sps. This can be reused in a later session opening the file straight into the Syntaxl - SPSS 
Syntax Editor window and using Run-»Current [or use Ctrl-R],

18. Using the HELP menu
All statistical analysis packages include an extensive Help system. If you have time, make 
use of the drop-down menu and look at the Statistics Coach facility that is loaded in this PC 
lab. It may not be available in the public PC labs but is a simple introduction to basic 
analysis.

When finished use File-»Exit saving any files you might like to refer to at a later date.
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This is the end of the tutorial. Please logout of the machine as normal 
or you are welcome to try to repeat anything that you have not 
understood and ask questions of the tutor.

This tutorial should have given you some insight into the basic 
structure and use of SPSS 12. Any comments or criticisms about this 
document are welcome by the Statistical Advisory Computing Staff. 
Please remember we are available, whenever possible, from 9.30 to 
12.30 in room G16, School of Applied Statistics, to help you construct 
the analysis of your data. We would be pleased to see you.


